В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DogiWars
DogiWars
13.09.2021 14:08 •  Информатика

Написать программу на паскале: дана s круга. найти его диаметр d и длину l окружности, ограничивающей этот круг, учитывая, что l = π×d, s = π×d2(в квадрате) /4

Ответ:
ulagrac8
ulagrac8
04.08.2020 20:28

const

 pi = 3.14;

var

 S, D, L: real;

begin

 write('Введите площадь круга: S = ');

 readln(S);

 D := 2 * sqrt(S / pi); { <-- Вычисляем диаметр круга }

 L := pi * D; { <-- Вычисляем длину окружности }

 writeln('Результат:');

 writeln(' D = ', D:0:2); { <-- Выводим диаметр на экран }

 writeln(' L = ', L:0:2); { <-- Выводим длину на экран }

 readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?