В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу, которая формирует массив из 12 случайных целых чисел , принадлежащих промежутку [-40; 40], и вычесляет сумму положительных чисел

Ответ:
NastyaResh666
NastyaResh666
09.10.2020 06:02

#include <iostream>

#include <ctime>

using namespace std;

void main()

{

srand(time(NULL));

const int size = 12;

int arr[size];

int c = 0;

for (int i = 1; i <= size; i++)

{

 arr[i] = rand() % 80 + (-40);

 if (arr[i] % 2 != 0)

  continue;

 c += arr[i];

}

cout << c << endl;

system("pause");

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?