В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
YAGA009
YAGA009
29.01.2021 11:00 •  Информатика

Заданы два целых числа a и b. составьте программу, определяющую, сколько целых чисел, которые одновременно удовлетворяют двум неравенствам x> a и x

Ответ:
leshakonovalov2
leshakonovalov2
09.10.2020 05:25

var a,b:integer;

begin

readln (a,b);

if a<b then write (b-1-a) else write(0)

end.

0,0(0 оценок)
Ответ:
Учен586
Учен586
09.10.2020 05:25

Ввод: a ^ b С/П.

- x>=0 05 0 С/П /-/ 1 - С/П


Согласен, отрицательный результат противоречит условию, исправил. Благодарю за замечание, был невнимателен.

Смысл кода такой:

X = a; Y = b;

X -= Y; Если не (X >= 0), переход на 05; X = 0; Стоп; [05] Смена знака; Y = X, X = 1; X -= Y; Стоп. На индикаторе X.

Рад, что мои решения кому-то интересны.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?