В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
avazjon2296
avazjon2296
05.12.2020 05:06 •  Информатика

Напишите программу, которая выводит символы с от n до м (в три столбца) напишите фрагмент , в котором будет определяться символ по своему коду напишите фрагмент , в которой будет определяться код символа

Ответ:
jamal55
jamal55
09.10.2020 05:30

var n,m,i,k:integer; c:char;

begin

// 1

write('n, m: ');

readln(n,m);

k:=0;

for i:=n to m do

begin

write(i,' - ',chr(i),'   ');

k:=k+1;

if k mod 3=0 then writeln;

end;

// 2

write('n: ');

readln(n);

writeln(n,' ',chr(n));

// 3

write('c: ');

readln(c);

writeln(c,' ',ord(c));

end.

Пример:

n, m: 40 60

40 - (   41 - )   42 - *    

43 - +   44 - ,   45 - -    

46 - .   47 - /   48 - 0    

49 - 1   50 - 2   51 - 3    

52 - 4   53 - 5   54 - 6    

55 - 7   56 - 8   57 - 9    

58 - :   59 - ;   60 - <    

n: 100

100 d

c: {

{ 123

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?