В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mvalinka
mvalinka
21.03.2020 07:28 •  Информатика

Составить программу для вычисления значения функции y=корень х + 5

Ответ:
Дашуля110506
Дашуля110506
09.10.2020 04:40
Код (выполнен и написан на языке С++)

#include <iostream>

#include <math.h> // для функции sqrt()

using namespace std;

int main()

{

   setlocale(LC_ALL, "Russian");

   int x;

   cout << "Введите x: ";

   cin >> x;

   if((x + 5) < 0){

       cout << "Корень из отрицательного числа не вычисляется!" << endl;

       return 0;

   }

   else {

       cout << "Корень из " << x + 5 << " равен " << sqrt(x + 5) << endl;

   }

   return 0;

}


Проверка:

Введите x: 139


Корень из 144 равен 12



Введите x: -5                                      

Корень из 0 равен 0



Введите x: -6                                      

Корень из отрицательного числа не вычисляется!

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?