В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Маха1437
Маха1437
25.08.2021 05:46 •  Информатика

Составьте программу на паскале, которая вводит 2 целых числа m и n и печатает все целые числа между m и n, делящиеся на 7, включая и сами эти числа. замечание: программа должна учитывать, что заранее не известно, какое из чисел m или n больше другого.

Ответ:
YTMrBreadYT
YTMrBreadYT
09.10.2020 03:43

var

   N, M, prov: longint;

begin

   readln(N);

   readln(M);

   if N < M then

   begin

       prov := N;

       while prov <= M do

       begin

           if prov mod 7 = 0 then

               writeln(prov);

           inc(prov);

       end;

   end

   else  

   begin

       prov := M;

       while prov <= N do

       begin

           if prov mod 7 = 0 then

               writeln(prov);

           inc(prov);

       end;

   end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?