В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
glebKoz
glebKoz
08.11.2021 11:51 •  Информатика

Составить программу на языке с# дан массив из случайных чисел. нужно переписать элементы, большие среднего арифметического, в начало, а остальные - в конец массива. выполнить с использованием второго массива

Ответ:
zelenkadi
zelenkadi
09.10.2020 03:31

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;


namespace avg_sort

{

   class Program

   {

       static void Main(string[] args)

       {

           const int N = 10;

           int[] Arr = new int[N];


           Random rand = new Random();

           Console.Write("Исходный массив: ");

           for (int k = 0; k < N; ++k)

           {

               Arr[k] = rand.Next() % 100;

               Console.Write("{0} ", Arr[k]);

           }

           Console.WriteLine();


           double avg = Arr.Average();

           int[] Bufer = new int[N];

           int i = 0, j = N - 1;


           Console.WriteLine("Среднее значение по массиву Avg = {0}", avg);

           for (int k = 0; k < N; ++k)

           {

               if (Arr[k] > avg)

               {

                   Bufer[i] = Arr[k];

                   i++;

               } else

               {

                   Bufer[j] = Arr[k];

                   j--;

               }

           }

           Arr = Bufer;


           Console.Write("Отсортированный массив: ");

           foreach (var el in Arr)

           {

               Console.Write("{0} ", el);

           }

           Console.WriteLine();

       }

   }

}



Составить программу на языке с# дан массив из случайных чисел. нужно переписать элементы, большие ср
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?