В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
rekomc
rekomc
19.02.2023 18:48 •  Информатика

За 1. дано двузначное число. напишите программу , которая определяет: есть ли среди цифр заданного целого двузначного числа одинаковые. 2. написать программу: ввести номер месяца и вывести название времени года. 3. ввести возраст человека (от 1 до 1500 и вывести его вместе с последующим словом "год", "года", "лет". смотри прикрепленный файл.

Ответ:
us6ipi2013
us6ipi2013
02.09.2020 09:50

1 задача

var a: string;

begin

 write('Введите двузначное число: ');

 readln(a);

 writeln((a.First() = a.Last()) ? 'Цифры одинаковы' : 'Цифры различаются');

end.

2 задача

var  

 month: integer;

 season: string;

begin

 write('Введите номер месяца: ');

 readln(month);

 case month of

   1,2,12: season := 'Зима';

   3..5:   season := 'Весна';

   6..8:   season := 'Лето';

   9..11:  season := 'Осень';

   else    season := 'Вы ввели неверный номер месяца';

 end;

 writeln(season)

end.

3 задача

var  

 age: integer;

 ending: string;

begin

 write('Введите возраст: ');

 readln(age);

 if (age mod 100 >= 10) and (age mod 100 <= 20)  

   then ending := 'лет'

 else

   case (age mod 10) of

     1: ending := 'год';

     2..4: ending := 'года';

     5..9, 0: ending := 'лет'

   end;

 write(age, ' ', ending)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?