В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Кети20060106
Кети20060106
08.11.2022 03:18 •  Информатика

1. составьте программу, которая: a) определяет коды двух введенных с клавиатуры символов. б) выполняет операцию сцепление трех введенных с клавиатуры символов. в) выполняет сравнение двух введенных с клавиатуры символов и выводят результат сравнение на экран. например: 'a'< 'б' , 'д'='д' , 'я'< 'ы' г)выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке возрастания их кодов.

Ответ:
ilyaneizvestno10
ilyaneizvestno10
09.10.2020 01:12

а), б)


var a, b, c: char;


begin


 writeln('Введите 3 символа');


 readln(a, b, c);


 writeln('Результат сцепления: ', a+b+c);


 if a>b then writeln(a,'>', b);


 if a>c then writeln(a,'>', c);


 if a=b then writeln(a, '=', b);


 if a=c then writeln(a, '=', c);


 if a<b then writeln(a, '<', b);


 if a<c then writeln(a, '<', c);


 if b>c then writeln(b, '>', c);


 if b<c then writeln(b, '<', c);


end.


в)


var a, b: char;


begin


 writeln('Введите 2 символа');


 readln(a, b);


 if a>b then writeln(b,'  ', a);


 if a<b then writeln(a,'  ', b);


 if a=b then writeln(a,'  ', b);


end.

если правильно дай лутший ответ

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?