В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
direcrtbyrage
direcrtbyrage
18.05.2022 09:50 •  Информатика

1) написать программу, которая предлагает пользователю пройти тест на знание таблицы умножения. для прохождения теста, пользователю нужно выбрать число, умножение на которое будет проверять компьютер и количество вопросов по завершении теста компьютер должен выдать результат в процентном соотношении.

Ответ:
maslyuk05
maslyuk05
09.10.2020 00:54

#include <iostream>

#include <cstdlib>

#include <ctime>


int main()

{

   std::srand(std::time(NULL));


   unsigned short int

       number,

       value,

       _value,

       correct = 0;

   std::cout << "Введите число, умножение на которое будет происходить, и кол-во вопросов: ";

   std::cin >> number >> value;


   _value = value;

   while(_value > 0)

   {

       unsigned int

           _number,

           tmp = 1 + std::rand() % 10;

       std::cout << number << " * " << tmp << " = ";

       std::cin >> _number;

       if(_number == tmp * number)

       {

           std::cout << "Верно." << std::endl;

           correct++;

       }

       _value--;

   }

   std::cout << "Процентное соотношение: " << 100 * (static_cast<float>(correct) / value) << "%."

       << std::endl;

}


1) написать программу, которая предлагает пользователю пройти тест на знание таблицы умножения. для
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?