В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1234567891155
1234567891155
26.04.2023 08:18 •  Информатика

Clrscr; 30 б составить программу на языке паскаль,возведения числа х в степень числа y.

Ответ:
Ramzi085
Ramzi085
21.08.2020 17:18

var

   x, y, result:real;

begin

   readln(x, y);

   result := 1;

   if y > 0 then

   begin

       while y <> 0 do

       begin

           result := result * x;

           y := y - 1;

       end;

   end

   else if y < 0 then

   begin

       while y <> 0 do

       begin

           result := result * x;

           y := y + 1;

       end;

       result := 1 / result;

   end

   else result := 1;

       

   writeln('x^y = ', result);


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?