В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
89994709040
89994709040
09.04.2023 20:19 •  Информатика

Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !

Ответ:
kiradawn260
kiradawn260
21.08.2020 17:00

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('Введите натуральное десятичное число:');

 var r: string := '';

 while n >= 2 do

   (r, n) := (n mod 2 + r, n shr 1);

 r := '1' + r;

 r.Println

end.

0,0(0 оценок)
Ответ:
H3RURG
H3RURG
21.08.2020 17:00

Program l;

var

n: integer;

s: String;  

begin  

readln(n);  

while n>0 do begin  

insert(chr(48+n mod 2),s,1);  

n:=n div 2;  

end;  

writeln(s);  

end.


Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?