В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
тигрица086
тигрица086
09.12.2020 09:42 •  Информатика

Написать программу вычисляющую чётность нечётность цифр и так чтобы при вводе нуля писалось что так делать нельзя !

Ответ:
MarusiaG
MarusiaG
08.10.2020 23:09

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var n:=Abs(ReadInteger('Введите целое число:'));

 if n.IsOdd then Println('Число нечетное')

 else

   if n=0 then Writeln('Ноль вводиить нельзя')

   else Println('Число четное')

end.

0,0(0 оценок)
Ответ:
volechka1
volechka1
08.10.2020 23:09

#include <iostream>



int main()

{

   int x;

   std::cout << "Введите число, которое нужно проверить: ";

   std::cin >> x;

   

   if(x == 0)

       std::cout << std::endl << "Нельзя писать такое число!";

   else if(x % 2 == 0)

       std::cout << std::endl << "Четное";

   else if(x % 3 == 0 || x == 1)

       std::cout << std::endl << "Нечетное";

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?