В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sveta11111111Love
Sveta11111111Love
06.09.2022 21:43 •  Информатика

Написать программу, которая на вход получает 2 множества, а при выходе даёт 4 множества. можно на любом языке программирования. а ещё если не сложно , на псевдокоде.

Ответ:
Mojo228
Mojo228
08.10.2020 23:06

Кроме C++ ничего не знаю.

g++ compiler


#include <iostream>

#include <algorithm>

#include <set>

#include <iterator>


int main()

{

   std::set<int>

       set1,//Первое входное множество(A)

       set2,//Второе выходное множество(B)

       set3,//Первое выходное(разность set1 и set2)

       set4,//xz

       set5,//A пересечение B

       set6;//A объединение B

   int

       N, M,

       temp;

   

   std::cout << "Введите размер первого и второго множеств:";

   std::cin >> N >> M;

   

   

   std::cout << std::endl << "Введите значения первого множества: ";

   for(int i = 0; i < N; i++)

   {

       std::cin >> temp;

       set1.insert(temp);

   }

   

   std::cout << std::endl << "Введите значения второго множества: ";

   for(int i = 0; i < M; i++)

   {

       std::cin >> temp;

       set2.insert(temp);

   }

   std::set_difference(set1.begin(), set1.end(), set2.begin(), set2.end(), std::inserter(set3, set3.begin()));

   std::set_difference(set2.begin(), set2.end(), set1.begin(), set1.end(), std::inserter(set4, set4.begin()));

   std::set_intersection(set1.begin(), set1.end(), set2.begin(), set2.end(), std::inserter(set5, set5.begin()));

   std::set_union(set1.begin(), set1.end(), set2.begin(), set2.end(), std::inserter(set6, set6.begin()));

   

   //вывод

   std::cout << "Множество А: ";

   std::copy(set1.begin(), set1.end(),

       std::ostream_iterator<int>(std::cout, " "));

   std::cout << std::endl;

   

   std::cout << "Множество B: ";

   std::copy(set2.begin(), set2.end(),

       std::ostream_iterator<int>(std::cout, " "));

   std::cout << std::endl;

   

   std::cout << "Множество А - B: ";

   std::copy(set3.begin(), set3.end(),

       std::ostream_iterator<int>(std::cout, " "));

   std::cout << std::endl;

   

   std::cout << "Множество B - A: ";

   std::copy(set4.begin(), set4.end(),

       std::ostream_iterator<int>(std::cout, " "));

   std::cout << std::endl;

   

   std::cout << "Множество A пересечение B: ";

   std::copy(set5.begin(), set5.end(),

       std::ostream_iterator<int>(std::cout, " "));

   std::cout << std::endl;

   

   std::cout << "Множество А объединение B: ";

   std::copy(set6.begin(), set6.end(),

       std::ostream_iterator<int>(std::cout, " "));

   std::cout << std::endl;

   return 0;

}

0,0(0 оценок)
Ответ:
elmira64
elmira64
08.10.2020 23:06

// PascalABC.NET 3.4, сборка 1766 от 25.08.2018


begin  

 var a := new HashSet<integer>(ReadArrInteger('Множество A ->', ReadInteger('Размер множества A =')));

 var b := new HashSet<integer>(ReadArrInteger('Множество B ->', ReadInteger('Размер множества B =')));

 a.Except(b).Print; Println(' - A\B');

 b.Except(a).Print; Println(' - B\A');

 a.Intersect(b).Print; Println(' - пересечение A и B');

 a.Union(b).Print; Println(' - объединение A и B');

end.

Пример ввода/вывода в приложении.



Написать программу, которая на вход получает 2 множества, а при выходе даёт 4 множества. можно на лю
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?