В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
anastasiataraso
anastasiataraso
26.08.2020 01:49 •  Информатика

Написать программу в паскале автобус провозит 50 пассажиров. из них 10 едут до первой станции, 20 - до второй, а остальные до конечной. стоимость билетов до каждой станции соответственно равна a,b,c. определите сколько рейсов должен делать автобус. чтобы выручка составила к руб?

Ответ:
Ivan190901
Ivan190901
08.10.2020 22:55

var a, b,c,k,d,e,g,h : integer;

var f : integer;

begin

writeln('Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел :');

readln(a,b,c);

writeln('Введите сколько рублей должна быть конечная выручка : ');

readln(k);

d := 10*a;

e := 20*b;

g := 20*c;

h := d+e+g;

f := h div k;

writeln(f, ' Рейсов нужно совершить нужно совершить.');

end.

Лог :

Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел :

1

1

1

Введите сколько рублей должна быть конечная выручка :  

50

1 Рейсов нужно совершить нужно совершить.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?