В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ibama
ibama
06.04.2022 02:50 •  Информатика

Написать программу, которая в файле находит самого высокого человека и выводит его данные.

Ответ:
P4k3T
P4k3T
08.10.2020 22:01

//Поскольку вы не указали структуру файла и язык программирования, то подберу их сам.

//ЯП: C#

//Структура: рост/имя/вес/страна проживания

Код:

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.IO;

namespace Prog

{

class Program

{

static void Main(string[] args)

{

string location = "C://Test//Persons.txt";

try

{

int size = File.ReadLines(location).Count();

if (size > 0)

{

List<string> person = new List<string>();

string[] tallestPerson = new string[4];

int maxHeight = -1;

int height = 0;

int index = 0;

StreamReader PersonsReader = new StreamReader(location, Encoding.Default);

for (int i = 0; i < size; i++)

{

person.Add(PersonsReader.ReadLine());

height = Convert.ToInt32(person[i].Remove(person[i].IndexOf("/")));

if (height > maxHeight)

{

maxHeight = height;

index = i;

}

}

string tmp = person[index];

int paramIndex = 0;

for (int j = 0; j < tmp.Length; j++)

{

if (tmp[j] != '/')

tallestPerson[paramIndex] += tmp[j];

else

paramIndex++;

}

Console.WriteLine("Самый высокий человек: " + tallestPerson[1]);

Console.WriteLine("Рост: " + tallestPerson[0] + " см");

Console.WriteLine("Вес: " + tallestPerson[2] + " кг");

Console.WriteLine("Страна проживания: " + tallestPerson[3]);

}

else

{

Console.WriteLine("Файл пустой!");

}

}

catch (Exception)

{

Console.WriteLine("Ошибка! Файл не нейден, либо нарушена его структура!");

}

finally

{

Console.ReadKey();

}

}

}

}


Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
Написать программу, которая в файле находит самого высокого человека и выводит его данные.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?