В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
гиений1509
гиений1509
06.04.2022 02:50 •  Информатика

Написать программу, которая сортирует записи в файле f по алфавиту по фамилиям.

Ответ:
newvf
newvf
08.10.2020 22:01

// PascalABC.NET

// Версия 3.4 сборка 1749 (18.08.2018)


begin

var (f, out) := (ReadAllLines('in.txt'), OpenWrite('in.txt'));

f.Select((t, i)-> (t.ToWords[0], i)).Sorted.ForEach(t -> begin Writeln(out, f[t[1]]) end);

out.Close;

end.


Файл, который использовал для проверки в приложении(совпадение с реальными именами - случайность).

Считывание и запись происходит в одном файле.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?