В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир

Сэкзаменом pascal: 1 : треугольник задан координатами своих вершин на плоскости. составить программу, которая определит, является ли он равносторонним, равнобедренным или разносторонним 2 : дано целое число n (n > 1). найти наибольшее целое число i, при котором выполняется неравнество 3^i < n

Ответ:
erkisha
erkisha
08.10.2020 21:31
PascalABC.NET 3.4

function L(x1,y1,x2,y2:real):=Sqrt(Sqr(x2-x1)+Sqr(y2-y1));

begin
  var (xa,ya):=ReadReal2('Введите координаты точки А(х,у):');
  var (xb,yb):=ReadReal2('Введите координаты точки B(х,у):');
  var (xc,yc):=ReadReal2('Введите координаты точки C(х,у):');
  var a:=L(xb,yb,xc,yc);
  var b:=L(xc,yc,xa,ya);
  var c:=L(xb,yb,xa,ya);
  var k:=a=b?1:0;
  k+=a=c?1:0;
  k+=b=c?1:0;
  case k of
  0:Writeln('разносторонний');
  1:Writeln('равнобедренный');
  else Writeln('равносторонний');
  end
end.



begin
  var n:=ReadInteger('n=');
  var i:=Trunc(Ln(n)/Ln(3));
  if 3**i=n then i-=1;
  Writeln(i)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?