В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
akhtyamovedgar
akhtyamovedgar
19.03.2021 20:41 •  Информатика

Составить программу, выводящую значение true или false. шахматный король за один ход может переместиться с одного заданного поля на другое (каждое после задано двумя координатами - целыми числами от 1 до 8). на паскале

Ответ:
Xtarlus
Xtarlus
08.10.2020 21:28

Program KING;

Var x,y,x1,y1: integer;

Begin

writeln('Введите координаты расположения Короля:');

write('Коор. x - '); readln(x);

write('Коор. y - '); readln(y);

writeln('Введите координаты клетки хода:');

write('Коор. x - '); readln(x1);

write('Коор. y - '); readln(y1);

if ((x = x1) and (y = y1))

then writeln('FALSE')

else if (abs(x1 - x) < 2)

then if (abs(y1 - y) < 2)

then writeln('TRUE')

else writeln('FALSE')

else writeln('FALSE');

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?