В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ikurgan
ikurgan
07.12.2022 06:53 •  Информатика

Написать программу на pascal, либо c++ и составить блок-схему даны натуральные числа a1, признак конца последовательности 99. найти количество положительных чисел и удвоенное количество отрицательных чисел.

Ответ:
Mafg
Mafg
11.08.2020 07:48

Подключи библиотеки iostream и Windows.h


int main() {

int nNumsCount = 0,

pNumsCount;

int number = 0;

while(std::cin >> number && number != 99){

if(number < 0)

++nNumsCount;

if(number > 0)

++pNumsCount;

}

std::cout << pNumsCount << '\n' << 2*nNumsCount << std::endl;

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?