В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
artik5990765
artik5990765
11.12.2021 01:20 •  Информатика

Написать программу в pascal даны число a> 0, числа x1, необходимо вводить числа x1, , пока сумма модулей введенных чисел будет меньше a. определить число введенных чисел. p.s в поисковике искал, нашел 2 какие-то странные программы, они мне не подходят

Ответ:
Hexihexi
Hexihexi
11.08.2020 07:48
Var
  a,x,k,s:integer;
begin
  Write('a=');
  Readln(a);
  k:=0;
  s:=0;
  while s<a do
  begin
    Read(x);
    s:=s+abs(x);
    Inc(k)
  end;
  Writeln('Введено чисел ',k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?