В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ZhEnYa9911
ZhEnYa9911
11.05.2020 12:48 •  Информатика

Составить программу, которая будет считывать введённое четырехзначное число. каждую цифру этого числа необходимо вывести в новой строке

Ответ:
карамелька5555
карамелька5555
16.08.2020 22:51
// PascalABC.NET

begin
   var num: integer;
   while true do
   begin
      num := ReadlnInteger('введите 4-х значное число, num =');
      if (num > 999) and (num <= 9999)
         then break;
   end;
   
   var str := num.ToString;
   
   foreach var x in str do
      Println(x)
end.
0,0(0 оценок)
Ответ:
den111111111113
den111111111113
16.08.2020 22:51
Var a,f:integer;
begin
write('Введите четырехзначное число: ');
readln(a);
f:=a div 1000;
writeln(f);
a:=a-1000*f;
f:=a div 100;
writeln(f);
a:=a-100*f;
f:=a div 10;
writeln(f);
a:=a-10*f;
writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?