Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
sadovskaya02
21.11.2022 18:54 •
Информатика
Заполнить линейный массив из 10 элементов случайными числами от -40 до 40. найти максимальный элемент массива. pascal abc
Ответ:
GuardiaN55
08.10.2020 21:10
Var
a: array [1..10] of integer;
i: byte;
max: integer;
begin
randomize;
max := -100;
for i := 1 to 10 do
begin
a[i] := random(81) - 40;
if a[i] > max then max := a[i];
write(a[i], ' ');
end;
writeln(#13+'Максимальный элемент = ', max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
oznobiseva2006
05.08.2022 12:20
Напишите программу, которая задает массив из 13 случайных целых чисел из промежутка от 0 до 100 и находит сумму всех чисел больших 50....
nyusha1990
28.09.2021 22:36
1. ( ) В одной из кодировок Unicode каждый символ кодируется 16 битами. Иван написал текст (в нём нет лишних пробелов): Рак, Весы, Орион, Дракон, Козерог, Близнецы, Андромеда,...
Shofer123
09.07.2020 14:30
Даны числа: 9; 50; 372; 3575; 10122. Используя MS Excel, вычисли среднее арифметическое данных чисел...
KOROTKOVAKATA
29.03.2020 13:25
Текст объемом в 5 Кбайт был перекодирован из Unicod в КОИ-8. Представьте расчет размера нового файла. 2-Текстовый файл в 16-битовой кодировке занял на диске 20 Кбайт. Сколько...
всёокок
30.09.2020 12:21
Измерьте информационный объем сообщения ура! закончились выразите этот объем в битах, байтах и килобайтах....
умница603
07.10.2022 04:50
Чем отличается обычный рабочий стол от компьютерного?...
Вика7473
24.01.2020 23:30
Какой категории нет во встроенных функциях? А) Математические B) Физические Б) Финансовые Г) Логические...
Vayton1337
26.04.2020 02:43
Заполните таблицу, перечислив все возможные опасные воздей- ствия, угрожающие информационной безопасности....
butera
16.06.2021 08:24
Почему мужская стерильность оказывается полезной при селекции некоторых культур?...
aielstar
16.06.2021 08:24
Почему из большого разнообразия видов животных, обитающих на Земле, человек отобрал для одомашнивания очень немного видов?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a: array [1..10] of integer;
i: byte;
max: integer;
begin
randomize;
max := -100;
for i := 1 to 10 do
begin
a[i] := random(81) - 40;
if a[i] > max then max := a[i];
write(a[i], ' ');
end;
writeln(#13+'Максимальный элемент = ', max);
end.