В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
milton555
milton555
14.10.2022 16:04 •  Информатика

Составить программу, используя оператор repeat. вводятся числа до тех пор пока не введется 0. определить, сколько среди них положительных (включая 0) и сколько отрицательных. (числа вводятся в одну переменную в цикле).

Ответ:
fdnk1
fdnk1
08.10.2020 20:03
Вот так можно решить

Program M;
var i : integer = 0;
    pologitelnie : integer = 0;
    otricatelnie : integer = 0;    a : array[0..100] of Integer;
begin
    repeat
        begin
        read (a[i]);
        if (a[i]>=0) then
            pologitelnie := pologitelnie + 1
        else
            otricatelnie := otricatelnie + 1;
        i := i + 1;
        end;
    until a[i-1] = 0;
    writeln('положительных: ', pologitelnie);
    writeln('отрицательных: ', otricatelnie);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?