В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gyon
gyon
07.10.2020 18:13 •  Информатика

Для заданного одномерного целочисленного массива mas, содержащего n произвольных положительных , отрицательных и равных нулю чисел, составить программу для вычисления: найти номер и значение последнего отрицательного числа массива. язык программирования с++

Ответ:
clon4
clon4
08.10.2020 19:50
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <array>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    array<int, 5> arr = { 2, -1, 5, -7, 9 };
    auto result = find_if(arr.rbegin(), arr.rend(), [](int i) { return i < 0 ? i : 0; });
    cout << *result;
}
0,0(0 оценок)
Ответ:
ната5810
ната5810
08.10.2020 19:50
#include "iostream"
 #include <Windows.h> 
using namespace std;
int main() { setlocale(LC_ALL, "Russian");
int n,m,index,value;
value = 0;
int mas[50];
cout << "Введите колличество элементов матрицы: ", cin >> n, cout <<endl;
for (int i = 0; i < n; i++){
cout << "Введите " << i << " элемент матрицы: ", cin >> m;
mas[i] = m;
if (m < 0) {
index = i;
 value = m;
 } 
 }
cout << "Заданная матрица: ";
for (int i = 0; i < n; i++){
  cout << mas[i] << " ";
}
cout << endl << "Номер последнего отрицательного числа: " << index << endl;
cout << "Значение последнего отрицательного числа: " << value << endl; system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?