Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
zhurovalyuda
24.10.2021 05:43 •
Информатика
Что будет напечатано в результате работы следующей программы var n,s: integer; begin n : =0; s : =0; while s< =150 do begin s : = s+30; n : =n+5 end; write(n) end.
Ответ:
poldin04
21.08.2020 15:55
Цикл будет выполняться до тех пор, пока переменная "s" меньше или равна 150.
Делим 150 на 30, так как при каждом шаге к "s" прибавляется по 30.
150/30 = 5.
s = 150. n = 5.
Получаем, что "s" = 150. Прибавим еще одну итерацию, так как цикл продолжает выполняться при s = 150.
s = 180.
Найдем "n", умножив 5 * 6 ("n" увеличивается на 5, количество повторов цикла - 6).
5 * 6 = 30.
s = 180. n = 30
В ответ пишем "n".
ответ: 30.
0,0
(0 оценок)
Популярные вопросы: Информатика
GameNooB
07.10.2022 09:29
Возможность выбора параметра абзаца собраны, в каком раздели меню программы Word? *...
adfvdrt
09.06.2020 23:18
УМОЛЯЮ! Обери із запропонованого, що належить до інформаційних процесів (декілька варіантів відповіді) * передавання викладення зберігання пошук демонстрація опрацювання...
gritana
26.03.2022 18:02
Ребята ИНФОРМАТИКА! На одной улице стоят в ряд 4 дома, в которых живут 4 человека: Алексей, Егор, Виктор и Михаил. Известно, что каждый из них владеет ровно одной из следующих...
NinjaKiller1337
26.02.2022 20:58
У исполнителя Омега две команды, которым присвоены номера: 1. прибавь 3; 2. раздели на b (b — неизвестное натуральное число; b ≥ 2). Выполняя первую из них, Омега увеличивает...
TheGrigory
10.05.2023 12:31
С++ написать программу получить все элементы массивов а, которые не входят в массив b (заранее не выдавать программы с кучей ошибок)....
Regardless777
16.03.2020 05:30
Вывести на экран значение логического выражения, которого должно быть true, если x лежит вне отрезков [2,5] [1,1] и false в противном случае....
tytik1
15.02.2020 11:30
Рассмотри изображение человека так же как на примере слева отмечено ухо на изображение справа покажи стрелками и подпиши толстую кишку колени и кисти человека !...
Daniilyushka
15.02.2020 11:30
Найти все m и n натуральных чисел, удовлетворяющих уравнению: 1! + 2! + 3! + + n! = m^2...
rufiyamama
15.02.2020 11:30
Нужно спростить уровнение. 8(6x-5)-4x(3x-3x в квадрате)-10xв кубе...
LeXonG
15.02.2020 11:30
Вкаком году был захват персией вавилона...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Делим 150 на 30, так как при каждом шаге к "s" прибавляется по 30.
150/30 = 5.
s = 150. n = 5.
Получаем, что "s" = 150. Прибавим еще одну итерацию, так как цикл продолжает выполняться при s = 150.
s = 180.
Найдем "n", умножив 5 * 6 ("n" увеличивается на 5, количество повторов цикла - 6).
5 * 6 = 30.
s = 180. n = 30
В ответ пишем "n".
ответ: 30.