В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу для решение следующей . введите с клавиатуры три числа. если все числа отрицательны и не равны между собой, то замените числа их квадратами, иначе найдите и выведите сумму этих чисел. выведите результаты на экран. хелп, паскаль

Ответ:
ХочуЗнатьВсе1
ХочуЗнатьВсе1
08.10.2020 19:05
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3;
  if (a<>b) and (a<0) and (b<0) and (c<0) then begin
    (a,b,c):=(a*a,b*b,c*c);
    Println(a,b,c)
    end
  else Writeln('Сумма равна ',a+b+c)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?