Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
minzilyana
21.01.2020 03:08 •
Информатика
Написать программу которая задаёт массив случайных чисел из 20элементов от 0 до 25 и просчитывает сумму четных значений элементов
Ответ:
KateKeta
08.10.2020 18:42
Var a: array[1..20] of Integer;
i,n,sum: Integer;
begin
for i:=1 to 20 do
begin
n:=random(25);
a[i]:=n;
writeln(i,' число: ',n);
end;
for i:=1 to 20 do
begin
if a[i] mod 2=0 then Inc(sum,a[i]);
end;
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
motovsavelymotOv
01.07.2021 00:46
Найти квадрат суммы, произведение и среднее геометрическое трёх различных переменных...
Вася1480
05.06.2020 00:54
Объём информационного сообщения равен 2^33 бит . чему равен объём этого сообщения в гбайтах ? ответ дайте в степенях двойки....
Aigggggg
05.06.2020 00:54
Какими можна сделать на слайде графические объекты?...
сусанна27
05.06.2020 00:54
Залание в экселе: в ячейку а1 ввести число. в ячейке а2 вывести текст: число четное или число нечетное...
Romizn
08.11.2021 01:01
Реши задачу. (ответ округли до целых). Сколько секунд потребуется модему, передающему сообщения со скоростью 128000 бит/с, чтобы передать сообщение объёмом 233 Кбайт? ответ:...
аноним4378
02.12.2020 03:29
Создать программу в abc pascal(с строк сделать): ввести строку состоящюю из различных символов и определить: 1) произведение цифр входяящих в эту строку(произведение может быть...
marsel234
02.12.2020 03:29
Переведите смешанное число из десятичной в пятеричную систему счисления( точность- три знака после запятой) 602,52...
katherinepierce1864
22.01.2022 16:44
Надо в pascal составить программу. 1) задает следующие вопросы и позволяет ввести ответы: как тебя зовут? введи номер класса в котором ты учишься. 2) выдает фразу : имя, закончишь...
dhdhfjd55
01.08.2022 19:12
Скільки народних шкіл працювали у Гетьманщині у другій половині 18 ст.?...
Whitestar123
17.06.2022 23:18
Сума двох чисел дорівнює 30. Одне із чисел у 5 рази менше за інше. Знайдіть ці числа...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,n,sum: Integer;
begin
for i:=1 to 20 do
begin
n:=random(25);
a[i]:=n;
writeln(i,' число: ',n);
end;
for i:=1 to 20 do
begin
if a[i] mod 2=0 then Inc(sum,a[i]);
end;
writeln(sum);
end.