В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sheilin111111
Sheilin111111
30.04.2022 19:33 •  Информатика

Составьте программу, запрашивающую у пользователя k целых чисел и вычисляющую произведение положительных. пример работы: окно вывода сколько чисел обработать? 5 введите число 2 введите число введите число введите число введите число произведение положительных чисел из 5 составляет 24 а то я уже сижу рыдать начинаю (через паскаль надо

Ответ:
Toma06000
Toma06000
08.10.2020 18:22
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Сколько чисел обработать?');
  var s:=1;
  loop n do begin
    var k:=ReadInteger('Введите число');
    if k>0 then s*=k
    end;
  Writeln('Произведение положительных чисел из ',n,' составляет ',s)
end.

Пример
Сколько чисел обработать? 5
Введите число 7
Введите число -4
Введите число 0
Введите число 9
Введите число -2
Произведение положительных чисел из 5 составляет 63
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?