В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MrEdgik
MrEdgik
20.11.2020 15:48 •  Информатика

Для паскаля є цілочисельний масив n*m елементів. знайти номер рядка з мінімальною сумою модулів елементів. (есть целочисленный массив n * m элементов. найти номер строки с минимальной суммой модулей элементов.) написать программу и объяснить что к чему

Ответ:
аолесдвда
аолесдвда
08.10.2020 17:28
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (n,m):=ReadInteger2('Количество строк и столбцов в массиве:');
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  Writeln(a.Rows.Select(r->r.Select(t->Abs(t)).Sum).ToArray.IndexMin+1)
end.

Для паскаля є цілочисельний масив n*m елементів. знайти номер рядка з мінімальною сумою модулів елем
0,0(0 оценок)
Ответ:
atanova2861
atanova2861
08.10.2020 17:28
//более простым языком
const
  maxn = 100;

type
  myarr = array [1..maxn, 1..maxn] of longint;

var
  a: myarr;
  n, m, i, j, sum, ini, max: longint;

begin
  readln(n, m);
  max := 0;
  for i := 1 to n do begin
    sum := 0;
    for j := 1 to m do begin
      read(a[i, j]);
      sum := sum + abs(a[i, j]);
    end;
    if (sum > max) then begin
      ini := i;
      max := sum;
    end;
  end;
  writeln(ini);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?