В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
darilinamoo
darilinamoo
07.01.2023 17:55 •  Информатика

Напишите программу, которая получает с клавиатуры натуральное число и определяет, простое оно или нет. для этого нужно делить число на все натуральные числа, начиная с 2, пока не получится деление без остатка. паскаль

Ответ:
дашулька223
дашулька223
08.10.2020 17:25
Var num, i:integer;
begin
readln(num);
for i:=2 to num do
   if num mod i = 0 then break;
if i = num then writeln('число простое')
else writeln('число составное');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?