В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SuperSwino
SuperSwino
15.12.2022 18:39 •  Информатика

Написать программу сортировки массива по возрастанию из 10 случайных элементов. паскаль

Ответ:
alievaaytan17
alievaaytan17
04.08.2020 15:25
Var a: array[0..9] of Integer;
i,k,b,c: Integer;
begin
for i:=0 to 9 do
begin
a[i]:=Random(100);
writeln(i+1,' число: ',a[i]);
end;
for i:=0 to 9 do
begin
for k:=0 to 9 do
begin
if a[i]<a[k] then
begin
b:=a[i];
c:=a[k];
a[i]:=c;
a[k]:=b;
k:=0;
end;
end;
end;
writeln('Числа по возрастанию:');
for i:=0 to 9 do
writeln(i+1,' число: ',a[i]);
begin
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?