В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yabreakneckkryt
yabreakneckkryt
24.11.2021 23:18 •  Информатика

Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. подсчитайте в этом массиве количество положительных и количество отрицательных значений.

Ответ:
anastasiysu77
anastasiysu77
08.10.2020 16:16
Var a: array[0..99] of Integer;
i,pol,otr: Integer;
begin
for i:=0 to 99 do
begin
a[i]:=random(41)-20;
end;
for i:=0 to 99 do
begin
if a[i]>0 then Inc(pol);
if a[i]<0 then Inc(otr);
end;
writeln('Положительных: ',pol);
writeln('Отрицательных: ',otr);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?