В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
446664Flu
446664Flu
26.09.2020 13:26 •  Информатика

Написать программу,находящую скорость или время или пройденное расстояние в зависимости от запроса пользователя.(авс паскаль)

Ответ:
Partners04
Partners04
08.10.2020 15:24
Program fgg;

var
x: String[10];
t, v, s: Real;

begin
Write('Что будем искать?: ');
ReadLn(x);
if x = 'скорость' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите время: ');
ReadLn(t);
WriteLn('Скорость=', s / t);
end
else if x = 'время' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите скорость: ');
ReadLn(v);
WriteLn('Время=', s / v);
end
else if x = 'расстояние' then
begin
Write('Введите скорость: ');
ReadLn(v);
Write('Введите время: ');
ReadLn(t);
WriteLn('Расстояние=', v * t);
end
else
WriteLn('Неверно указано, что будем искать.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?