В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
emilking
emilking
10.01.2022 01:16 •  Информатика

Составить программу, проверяющую, является ли заданное натуральное число совершенным, т.е. равным сумме своих положительных делителей, кроме самого этого числа. на с++, с цикла с предусловием или постусловием.

Ответ:
lenova32
lenova32
08.10.2020 14:42
#include <iostream>
using namespace std;
int main(){    int i, num, sum;        sum = 0;    i = 1;    cin >> num;    while (i < num)    {        if (num % i == 0)        {            sum += i;        }        i++;    }    if (sum == num) {        cout << sum;    }    return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?