В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Alina12345611109
Alina12345611109
06.06.2023 06:19 •  Информатика

Составить программу вычисления среднего арифметического значение четных по значению элементов массива. элементы нумеруются с 0 до 49 и с датчика случайных чисел из диапазона [0,300]

Ответ:
НастюшКа50471
НастюшКа50471
08.10.2020 14:38
Var a: array[0..49] of Integer; sr:real;sum,i,n: integer;beginwriteln('Исходный массив');for i:=0 to 49 do begina[i]:=Random(300);write(a[i]:4);if a[i] mod 2 = 0 then begin sum:= sum + a[i]; n:= n +1; end;end;sr:= sum / n;writeln;writeln('Cреднее арифметическое значение четных ',sr);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?