Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
donczowakateri
20.07.2021 07:43 •
Информатика
Составить программу, которая для любого натурального числа печатает на естественном языке количество цифр в записи этого числа.составить программу на паскале.!
Ответ:
wwwlikaigor123
08.10.2020 14:41
Var
a:real;
begin
WriteLn('Введите чтсло');
readln(a);
Write('В записи этого числа ');
case a of
1..9 : Write ('одна цифра');
10..99 : Write ('две цифры');
100..999 : Write ('три цифры');
1000..9999 : Write ('четыре цифр');
10000..99999 : Write ('пять цифр');
100000..999999 : Write ('шесть цифр');
else Writeln('Данное число слишком велико');
end;
end.
0,0
(0 оценок)
Ответ:
sweetmur
08.10.2020 14:41
Var a:uint64;
k:Integer;
begin
write ('Введите число: ');
readln (a);
repeat
k:=k+1;
a:=a div 10
until a=0;
writeln('Количество цифр: ',k)
end.
var a:string;
begin
write ('Введите число: ');
readln (a);
writeln('Количество цифр: ',Length(a))
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vika160805v
27.01.2023 11:59
Дан массив а(15). его элементы случайным образом от -35 до 50. найти сумму и среднее значение отрицательных эл-тов, сумму и кол-во положительных эл-тов. решить всё в паскале...
ĪīDanilaīī
19.11.2022 05:20
Кто такой клод шеннон и чем он 0н знаменит...
levkim
10.02.2021 14:16
Какова вероятность того что ваш друг родился зимой? в декабре? 21 числа?...
nikita200310266xcute
10.02.2021 14:16
Однажды программист вася решил послать своему другу письмо. он подробно рассказал в нем, как у него дела. и, в конце концов, вышло большое послание. но почта не позволяет пересылать...
маргарита00000000
26.11.2020 06:45
Кем и когда был введён термин гипертекст...
FeGLoCk
15.01.2021 10:23
Определите значение переменной а после выполнения данного алгоритма: а := 10 b := 4 b := 200-а*b а := b/20*а В ответе укажите одно целое число — значение переменной а....
0m1ib6c
19.02.2020 19:59
Нарисовать такую мышку в паскале Хоть этот раз а...
leo00000
10.07.2022 17:30
Процесс восстановления показан схемой: 1) p-3 → p0 ; 3) p+5 → p0 ; 2) p0 → p+5 ; 4) p+3 → p+5...
Приветипока
10.07.2022 17:30
Спишите предложения. подчеркнет дополнения.печник сложил печь. печь стоит в углу. рыбаки поставили сеть. сеть понравилась. дерево пустила новые корни. девочки поливают дерево....
karakatitsa1
10.07.2022 17:30
Что значит выражение на тела действует сила тяжести 20н...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a:real;
begin
WriteLn('Введите чтсло');
readln(a);
Write('В записи этого числа ');
case a of
1..9 : Write ('одна цифра');
10..99 : Write ('две цифры');
100..999 : Write ('три цифры');
1000..9999 : Write ('четыре цифр');
10000..99999 : Write ('пять цифр');
100000..999999 : Write ('шесть цифр');
else Writeln('Данное число слишком велико');
end;
end.
k:Integer;
begin
write ('Введите число: ');
readln (a);
repeat
k:=k+1;
a:=a div 10
until a=0;
writeln('Количество цифр: ',k)
end.
var a:string;
begin
write ('Введите число: ');
readln (a);
writeln('Количество цифр: ',Length(a))
end.