В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
NataNati
NataNati
20.01.2021 16:13 •  Информатика

Напишите программу к . найти количество отрицательных чисел, вводить пока не будет 3.

Ответ:
Ludok0309
Ludok0309
08.10.2020 14:39
1) Программа будет запрашивать ввод новых чисел, пока он не введёт число 3:

var i,count,n: Integer;
begin
while i<>3 do
begin
writeln('Введите число');
readln(n);
if n<0 then inc(count);
i:=n;
end;
writeln('Кол-во: ',count);
end.

2) Программа будет запрашивать ввод чисел, пока отрицательные числа в сумме не будут равны числу 3:

var count,n: Integer;
begin
while count<>3 do
begin
writeln('Введите число');
readln(n);
if n<0 then inc(count);
end;
writeln('Кол-во: ',count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?