Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
тчочолаовов1
15.04.2020 21:21 •
Информатика
Составить программу вычисления произведения положительных и суммы отрицательных элементов массива a.проверить работу программы на заданном массиве a(11). на паскале
Ответ:
витя10
08.10.2020 14:23
Program p1;
uses crt;
var a:array[1..11] of integer;
i,p,s:integer;
begin
for i:=1 to 11 do begin
a[i]:=random(30)-10;
write(a[i]:4);
end;
p:=1;
s:=0;
for i:=1 to 11 do begin
If a[i]>0 then begin
p:=p*a[i];
end;
If a[i]<0 then
s:=s+a[i];
end;
writeln;
writeln('Произведение :',p);
writeln('Сумма :',s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
оллл11
01.11.2020 04:49
Внекотором каталоге хранился файл txt.doc. после того, как в этом каталоге создали подкаталог и переместили в созданный подкаталог файл txt.doc, полное имя файла стало р: doc\...
vladdancer
01.11.2020 04:49
Составьте программу либо через функцию или можно через процедуру: 1)вычислить сумму квадратов простых чисел,лежащих в интервале (m,n). 2)вычислить сумму простых не превосходящих...
Ira511
22.08.2021 09:55
Как вырезать ненужную часть видео при обработке в программе videopad...
SabZero55
27.11.2022 02:18
Найти и вывести сумму всех чётных чисел в диапазоне от 0 до 10....
reshitov123
04.01.2023 14:39
С цикла for вывести любую строчку из стихотворения или песни 7 раз...
Laura11111111111
30.04.2021 15:56
С цикла for вывести 10 первых степеней двойки....
КаземираМалевична
11.12.2020 21:08
Решите брату два задания 7 класс алгебра...
NObrains0
15.11.2020 11:10
Напишите как оформить титульный лист проекта 8 класс...
кукареку18
12.09.2021 15:47
Найдите длину медианы LM треугольника, изображённого на рисунке, если KS=24...
littleeeprincess
24.08.2022 16:10
. Подобрать однокоренные слова(Полевой,табак,лепестки)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses crt;
var a:array[1..11] of integer;
i,p,s:integer;
begin
for i:=1 to 11 do begin
a[i]:=random(30)-10;
write(a[i]:4);
end;
p:=1;
s:=0;
for i:=1 to 11 do begin
If a[i]>0 then begin
p:=p*a[i];
end;
If a[i]<0 then
s:=s+a[i];
end;
writeln;
writeln('Произведение :',p);
writeln('Сумма :',s);
end.