В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
okrushko
okrushko
16.04.2023 20:14 •  Информатика

Составьте программу на паскале для пяти чисел по убыванию и нахождение их суммы

Ответ:
lyizadenikaeva
lyizadenikaeva
08.10.2020 12:32
Var
  A: array [1 .. 5] of real;
  i, j: byte;
  sum, tmp: real;

begin
  sum := 0;

  { Заполнение массива }
  for i := 1 to 5 do
  begin
    write('A[', i, '] = ');
    readln(A[i]);
    sum := sum + A[i]; // подсчет суммы
  end;
  writeln(#13 + 'Сумма элементов = ', sum);

  { Сортировка по убыванию }
  for i := 1 to 4 do
    for j := i + 1 to 5 do
      if A[i] < A[j] then
      begin
        tmp := A[i];
        A[i] := A[j];
        A[j] := tmp;
      end;

  { Вывод }
  writeln('Отсортированный массив: ');
  for i := 1 to 5 do
    write(' ', A[i]);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?