В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
snikola97
snikola97
28.09.2020 09:59 •  Информатика

Даны n целых чисел. составить программу, которая выводит в ответ только те из них, которые кратны трём, но при этом оканчиваются только на 9. проверка n = 15 2 3 19 39 45 12 999 8 15 10 69 89 199 9 16 ответ 39 999 69 9

Ответ:
sweetdog7
sweetdog7
08.10.2020 12:17
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqInteger(ReadInteger('n ='))
      .Where(t->(t mod 3=0) and (Abs(t) mod 10=9)).Println
end.

Пример
n = 15
2 3 19 39 45 12  999 8 15 10 69 89  199 9 16
39 999 69 9
0,0(0 оценок)
Ответ:
void1231
void1231
08.10.2020 12:17
PascalABC.NET

var
n,a:Integer;
list: List<integer> := new List<integer>;
begin
Write('n=');
Read(n);
for var i:= 1 to n do
begin
Read(a);
if (a mod 3 = 0) and (a.ToString().EndsWith('9')) then
list.Add(a);
end;
WriteLn(list);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?