В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Miya5koka
Miya5koka
15.10.2020 01:12 •  Информатика

Напишите программу в паскаль которая выводит квадраты первых 7 нечетных чисел в массиве

Ответ:
Gotaur
Gotaur
08.10.2020 12:07
Не знаю как именно нужно было заполнять массив, поэтому сделал рандом
Var a:array[1..20] of Integer ;
n,i:integer;
Begin
n:=7;
WriteLn('Массив');
For i:= 1 to 20 do
begin
a[i]:=Random(20);
Write(a[i]:3);
end;
Writeln;
Writeln('Квадраты первых 7 нечетных чисел');
For i:=1 to 20 do
if (a[i] mod 2 = 1) and (n<>0)then
begin
Write(sqr(a[i]):4);
n:=n-1;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?