В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
serega7315
serega7315
20.10.2021 05:34 •  Информатика

Паскаль. напишите программу для решения квадратного уравнения

Ответ:
pollyj
pollyj
10.09.2020 14:54
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите через пробел a,b,c:');
  var d:=b*b-4*a*c;
  if d<0 then Writeln('Нет действительных корней')
  else
    if d=0 then Writeln('Единственный корень ',-b/2/a)
    else begin
      d:=Sqrt(d);
      Writeln('Два корня: ',(-b-d)/2/a,' ',(-b+d)/2/a)
      end
end.

Пример
Введите через пробел a,b,c: 2.6 -3.1 0.15
Два корня: 0.0505284246495728 1.14177926765812
0,0(0 оценок)
Ответ:
st1rb1t
st1rb1t
10.09.2020 14:54
Program kv;
var
   a,b,c,d:real;
begin
   write('Введите a,b и c: ');
   read(a,b,c);
   d:=sqr(b)-4*a*c;
   if(d<0) then writeln('Корней нет')
      else if(d=0) then writeln('Корень равен ',(-b/(2*a)))
         else writeln('Первый корень равен ',((-b+sqrt(d))/(2*a)),' Второй корень равен ',((-b-sqrt(d))/(2*a)));
end.
 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?