В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
plplem9999
plplem9999
21.04.2021 07:20 •  Информатика

9класс информатика дан целочисленным массив из 20 элементов, все элементы которого положительные числа , не превосходящие 100. напишите программу которая находит и выводит номер элемента , имеющего максимальное количество целочисленных делителей ( если таких элементов несколько, то номер любого из них). на паскале абс заранее

Ответ:
Lizavladimir07
Lizavladimir07
08.10.2020 11:19
Const n=20;
var a: Array [1..n] of integer;
i,j,m,d,dm: Integer;
begin
for i:=1 to n do
a[i]:=random(100);
writeln (a);
for i:=1 to n do
begin
d:=0;
for j:=1 to a[i] do
if a[i] mod j = 0 then d:=d+1;
if d>dm then
begin
dm:=d;
m:=i
end
end;
writeln (m)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?