В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
исма19
исма19
31.05.2020 12:50 •  Информатика

Но только решение должно быть не через массив, а через циклы (либо repeat, либо for, либо while). : последовательно вводится n целых чисел. найдите минимальное и максимальное число из введенных чисел.

Ответ:
Dacha111111111
Dacha111111111
08.10.2020 11:17
Var n,i,max,min,a: integer;
begin
write('Введите количество чисел (N): ');
readln(n);
write('Введите число: ');
readln(a);
max:=a;
min:=a;
for i := 1 to n-1 do
begin
write('Введите число: ');
readln(a);
if a>max then max:=a;
if a<min then min:=a
end;
writeln('Максимальное число в последовательности: ',max);
writeln('Минимальное число в последовательности: ',min)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?