В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
лена1278
лена1278
19.05.2022 20:33 •  Информатика

Напишите программу вычисления выражения: s=1! +2! +3! ++n! 5-9 класс здесь n! - факториал числа n. n! =1*2**(n-1)*n. используйте функцию вычисления факториала.

Ответ:
Gangstar777437g
Gangstar777437g
08.10.2020 10:36
//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
var f: integer->real:=x->range(1,x).Aggregate(Real(1),(a,b)->a*b);
var n:=ReadInteger('n=');
write(range(1,n).Select(x->f(x)).Sum)
end.
0,0(0 оценок)
Ответ:
джемре
джемре
08.10.2020 10:36
Var s,j,k:longint;
function f(n:byte):longint;
var f1:longint;
i:integer;
begin
if n<1 then f1:=1
else begin
f1:=1;
for i:=1 to n do
f1:=f1*i;
end;
f:=f1;
end;
begin
s:=0;
readln(k);
for j:=1 to k do
s:=s+f(j);
writeln(s);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?