В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Mehribonim
Mehribonim
14.06.2022 10:29 •  Информатика

Паскаль напишите программу, которая выводит на экран массив в в одну строку и определяет количество четных и количество нечетных элементов.

Ответ:
Melissa607
Melissa607
08.10.2020 09:52
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var b:=ArrRandom(ReadInteger('n='),-50,50); b.Println;
  Writeln('Четных элементов ',
      b.Where(t->t.IsEven).Count,
      ', нечетных ',
      b.Where(t->t.IsOdd).Count)
end.

Пример
n= 20
-18 -1 48 -31 -18 -34 -42 20 -30 14 -16 45 50 0 -18 39 45 19 -10 16
Четных элементов 14, нечетных 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?