В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
FedushkinDmitry95
FedushkinDmitry95
22.02.2021 21:17 •  Информатика

Дано трехзначное натуральное число. написать программу, которая определяет верно ли, что сумма цифр этого числа является нечетной ( число вводится с клавиатуры).

Ответ:
crustiYurasova
crustiYurasova
08.10.2020 09:49
Var a,s:integer;
begin
 readln(a);
 s:=a div 100+a div 10 mod 10+a mod 10;
 if s mod 2=1 then writeln('Верно. s = ',s,' - нечётна')
 else writeln('Нет. s = ',s,' - чётна')
end.

Пример:
251
Нет. s = 8 - чётна
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?