В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
radugraduga887
radugraduga887
15.02.2023 20:02 •  Информатика

Составить программу на языке паскаль, которая создает массив из 10 элементов целочисленного типа и заполняет массив первыми 10 четными числами (начиная с числа 2). программа должна вывести значения последних 3 элементов массива.

Ответ:
TheBrayn
TheBrayn
08.10.2020 09:30
Const last = 3;//сколько последних
const count = 10;//всего чисел
var
arr:array [1..count] of Integer;
i,a:Integer;
begin
while i<count do
begin
a+=1;
if a mod 2 = 0 then
begin
i+=1;
arr[i]:= a;
end;
end;
for i:= 1 to last do
WriteLn(arr[count-last+i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?