В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mokantatiana
mokantatiana
29.06.2021 17:52 •  Информатика

Напишите программу, которая находит произведение двух наименьших чисел из последовательности натуральных чисел. программа получает на вход натуральные числа, количество чисел неизвестно (но не менее двух), ввод последовательности заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. значения чисел не превышают 30000. программа должна вывести одно число: произведение двух чисел, значения которых в данной последовательности наименьшие

Ответ:
HAPKOMAH2281
HAPKOMAH2281
08.10.2020 08:37
//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToList;
var m:=a.Min;
a.Remove(m);
write(m*a.Min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?